System Navigation Issue

Incident Report for Floorzap

Resolved

This incident has been resolved.
Posted May 21, 2026 - 09:50 CDT

Monitoring

The intermittent server errors reported earlier have been resolved. Our team has identified and addressed the root cause, and normal service has been restored. We are actively monitoring to confirm stability.

If you continue to experience issues, please contact support at support@floorzap.com.
Posted May 21, 2026 - 09:43 CDT

Investigating

Floorzap is currently experiencing intermittent server errors. Users may encounter failed requests, error messages, or pages that do not load correctly on retry. Our team is investigating and updates will be posted as additional information becomes available.
Posted May 21, 2026 - 08:40 CDT
This incident affected: Production.