Elevated Server Load Causing Service Disruption

Incident Report for Floorzap

Resolved

The Floorzap system issue has been successfully resolved, and all services are now functioning as expected.
Thank you for your patience and understanding while our team worked diligently to restore full functionality.
Posted Jul 29, 2025 - 16:37 CDT

Update

We’ve identified the root cause of the service disruption as elevated server load triggering performance issues across the platform. To accelerate recovery, we’ve temporarily paused access to Floorzap to reduce further strain.
We expect to restore full access within the next 1–2 hours.

Our team is actively working to bring all services back online and will continue to post updates here as progress is made.

Thank you for your continued patience.
Posted Jul 29, 2025 - 14:47 CDT

Monitoring

Our team has identified the root cause as an unexpected spike in CPU usage on a core service. Mitigation is underway and performance may improve intermittently as load normalizes. We will provide the next update within 30 minutes or as soon as more information becomes available. Thank you for your patience.
Posted Jul 29, 2025 - 13:10 CDT

Investigating

We are currently investigating elevated CPU usage on our servers, which is causing degraded performance and limited access for some users. Our engineering team is monitoring the situation closely. We will provide the next update within 30 minutes or as soon as more information becomes available. Thank you for your patience.
Posted Jul 29, 2025 - 12:39 CDT
This incident affected: Production.